Вопрос: Google App Engine JSP не может развертываться: java.lang.RuntimeException: не удается получить компилятор System Java. Пожалуйста, используйте JDK, а не JRE


это, надеюсь, что-то простое, но ... Eclipse работает относительно хорошо для всего, кроме развертывания в GAE.

Я могу запустить приложение GAE локально, но когда я пытаюсь установить его в Google, я получаю это сообщение:

java.lang.RuntimeException: Cannot get the System Java Compiler. Please use a JDK, not a JRE.

Я установил путь сборки к JDK.

Это также происходит при попытке развернуть один и тот же проект из нескольких систем (win7 и win8), поэтому я подозреваю, что проблема связана с самим проектом. Этот конкретный проект уже существует и уже работает на google в течение многих лет.

Интересно, что эта ошибка появляется только тогда, когда у меня есть .jsp-файлы в моем приложении для развертывания. Если я удалю файлы jsp, он будет развернут без ошибок. (нужны файлы jsp tho)

благодаря

ссылка на образ моего пути сборки


33


источник


Ответы:


У меня была такая же проблема, и я смог успешно ее развернуть после принудительного использования Eclipse JRE в моей директории SDK (Win 7 64 бит). Чтобы заставить Eclipse использовать конкретную JRE, см. это , Кажется, что JVM, который использует Eclipse, JVM, созданный приложением, и JVM, который использует appconfig, должны быть одинаковыми. Надеюсь, это поможет вам и вашей ситуации.


60



Я попытался установить, что мой проект jre будет таким же, как мой eclipse jre в соответствии с ответом AlohaCode. Это было недостаточно для меня. Ответ был в моем пути к классу, есть java.exe в C: \ windows \ system32, который был ПЕРЕД моей переменной java home. Решение состоит в том, чтобы поместить исходный путь java перед входом C: \ windows \ system32. Я нашел ответ здесь: 2FL5sJ "> https://groups.google.com/forum/?fromgroups=#!msg/google-appengine-java/RyFybJWUhU4/78UE_2FL5sJ


12



В Eclipse перейдите к: Window-> Preferences-> Java-> Installed JREs, add-> Standard VM TO JDK PATH \ JRE. и если у вас была проверена проверка JRE, сначала снимите флажок и проверьте этот jre


2



Данный совет решил мою проблему. -vm аргумент не может быть первой строкой.

-vm

C:\Program Files (x86)\Java\jdk1.7.0_51\bin\javaw.exe

2



Установка -vm в eclipse.ini не помогла. Все остальные настройки, казалось бы, указывали на JDK. Из отчаяния я удалил все JRE из своей системы, оставив только JDK. Следствием этого было то, что Eclipse не запускался, поскольку каталог JDK bin не был на моем PATH (здесь Windows 8). Добавление этого параметра в системные переменные среды привело к запуску Eclipse. После этого я смог развернуть приложение.


0



Удаление Файл JRE  расположенный в моем C:/Program Files(*86)/Java папка, повторное открытие Eclipse IDE разрешило проблему.

Я установил Java JDK в свой C:/Program Files/Java которая ранее не была обнаружена.


-2