Вопрос: Добавить небезопасный реестр в Docker


У меня есть докер 1.12, работающий на CentOS. Я пытаюсь добавить в него небезопасный реестр, и все, что упоминается в документации, просто не работает. Система использует systemd поэтому я создал /etc/systemd/system/docker.service.d/50-insecure-registry.conf файл.

$ cat /etc/systemd/system/docker.service.d/50-insecure-registry.conf
[Service]
Environment='DOCKER_OPTS=--insecure-registry="hostname.cloudapp.net:5000"'

После загрузки демона и перезапуска службы докеров система systemd показывает, что существует переменная окружения

$ sudo systemctl show docker | grep Env
Environment=DOCKER_OPTS=--insecure-registry="hostname.cloudapp.net:5000"

Но когда я бегу docker info Я не вижу, что добавлен небезопасный реестр

$ docker info
........
Registry: https://index.docker.io/v1/
WARNING: bridge-nf-call-iptables is disabled
WARNING: bridge-nf-call-ip6tables is disabled
Insecure Registries:
    127.0.0.0/8

Нажатие изображений на hostaneme.cloudapp.net с

Pushing application     (hostname.cloudapp.net:5000/application:latest)...
The push refers to a repository     [hostname.cloudapp.net:5000/mozart_application]
ERROR: Get https://hostname.cloudapp.net:5000/v1/_ping: http: server gave HTTP response to HTTPS client

Есть ли что-то, что можно сделать? Я что-то упускаю ?

ОБНОВИТЬ

Решена проблема, добавив файл /etc/docker/daemon.json со следующим содержанием

{
    "insecure-registries" : [ "hostname.cloudapp.net:5000" ]
}

И затем перезапустите докер

sudo systemctl daemon-reload
sudo systemctl restart docker

После этого небезопасного реестра hostname.cloudapp.net:500 работает.


37


источник


Ответы:


(Копирование ответа из вопроса)

Чтобы добавить небезопасный реестр докеров, добавьте файл /etc/docker/daemon.json со следующим содержанием:

{
    "insecure-registries" : [ "hostname.cloudapp.net:5000" ]
}

а затем перезапустите докер.


62



Создание файла /etc/docker/daemon.json и добавление ниже содержимого после перезагрузки докеров на CentOS 7 разрешило проблему.

{
    "insecure-registries" : [ "hostname.cloudapp.net:5000" ]
}

1